Saltar al contenido

Categorías

Vulnerabilidades en Prestashop

En enero de este año, los usuarios registrados de Prestashop recibieron un email que indicaba la vulnerabilidad a un bot denominado «XsamXadoo.Bot» que afecta a la herramienta PHPUnit. Seguramente te habrás alarmado ante tal vulnerabilidad sin embargo, puede solucionarse.

Esta vulnerabilidad notificada por Francis Ladeuil, afectó a algunas tiendas  PrestaShop con las versiones 1.6 y 1.7. Debes tener presente que las versiones anteriores a  PHPUnit 7.5.19 y 8.5.1 son vulnerables. Este malware puede ser utilizado para acceder a una tienda online y apoderarse de ella. Por tanto,  no debes arriesgarte y realizar la revisión correspondiente. Recuerda que tus datos pueden ser robados y así como los de tus clientes, afectando tu  integridad como empresa y tus resultados.

vulnerabilidades-en-prestashop

¿Que es el PHPUnit y cómo soluciono la vulnerabildad?

En primer lugar hablemos del PHPUnit. La utilidad de esta herramienta utilizada por  los desarrolladores de tiendas online es la construcción de módulos y no es requerida  para el funcionamiento normal del sitio web. Por tanto, debes eliminarlo para evitar el ataque.

Sin embargo, la versión 1.7.6.1 no la incluye, y es realmente poco probable que como usuario la encuentres en la instalación. Se han realizado diversas revisiones y solo dos de una gran cantidad de tiendas incluían este archivo en el modulo de autoupgrade.

Prestashop, en su mensaje, indica claramente cual es el procedimiento a seguir para resolver esta vulnerabilidad en nuestra tienda online. En tal sentido, solo debes seguir estos pasos:

  • Ubica la carpeta «Vendedor» en el nivel raíz de tu sitio web Prestashop en el Servidor
  • Si detectas que la carpeta del proveedor incluye una carpeta denominada «phpunit», tu tienda puede ser vulnerable a este malware
  • Elimina la carpeta «phpunit» y todo el contenido.

Prestashop confirmó que hay varias tiendas que son vulnerables y que están en riesgo de ser atacadas, mientras que otras ya están comprometidas. Por tanto la mejor opción es, además del anteriormente descrito, eliminar este directorio ingresando por FTP a la instalación, ubicar la carpeta «Vendor» y verificar si el archivo «phpunit»se encuentra en el directorio. Si este fuera el caso, solo debes eliminarlo. Este paso no afectará la instalación ni el funcionamiento de tu tienda.

Otra opción a la que puedes recurrir es acceder al directorio módulos para tratar de ubicar dentro de cada una de ellas la carpeta «vendor» con el archivo «phpunit» en su interior. Este paso tampoco afectará el funcionamiento de dicho módulo, sin embargo no elimines ningún otro elemento.

Recuerda que con estos pasos puedes proteger a tu eCommerce de este malware, sin embargo tu sitio pudiera estar comprometido. Si no encontraste la carpeta «phpunit» en ninguno de los módulos, tu tienda está a salvo.

Es fundamental que todos tus módulos Prestashop y la plantilla que utilices estén actualizados, ya que con frecuencia este tipo de problemas se presentan por la ausencia de actualizaciones. Pero hay módulos y plantillas que ya están obsoletos y no los puedes actualizar si, por ejemplo, tu tienda usa la versión 1.6. En tal caso, no te queda más remedio que actualizar manualmente Prestashop de versión 1.6 a 1.7. Y también debes tener presente que la versión PHP en tu servidor o alojamiento debe mantenerse actualizada.

vulnerabilidades-en-prestashop

Módulos Desarrollados para eliminar la vulnerabilidad

Módulo Slkphpunit v1.0.2

Como una solución a esta vulnerabilidad un desarrollador ha creado un módulo que permite realizar la tarea de detección y eliminación de este archivo de manera automática, la cual parece funcionar adecuadamente. Sin embargo, las pruebas se realizaron en una instalación de prueba, de una tienda afectada. Por tanto, no podemos confirmar que este módulo afecte de alguna manera a las tiendas online. A pesar de ello no se han observado elementos que comprometan la seguridad de la tienda online.

El desarrollador ha publicado el módulo en su blog, en idioma francés, aunque puedes traducirla al español fácilmente.  Su instalación es similar a la de cualquier módulo Prestashop.

Módulo comprobador de vulnerabilidad PHPUnit PrestaShop 1.6 y 1.7

Este módulo permite analizar la totalidad de los archivos de la librería «phpunit»  y  eliminarlos de manera muy sencilla. Si bien es cierto que la eliminación del archivo puede realizarse manualmente, si cuentas con una gran cantidad de módulos, el proceso puede ser bastante tedioso.

Este modulo de manera automática escaneará todos los directorios Prestashop en que posiblemente se pueda haber alojado la librería «phpunit», así como en los módulos que tengas instalados.  Una vez que concluya la búsqueda proporcionará un listado con las librerías que haya encontrado, ofreciéndote la opción de eliminarlas. Esté modulo es de distribución gratuita.

A pesar de que hayas realizado el análisis y eliminado los directorios que hacen vulnerable a tu web, es posible que tu tienda esté comprometida. Debes recordar que este tipo de atacantes suelen añadir archivos o modificar algunos existentes.Sin embargo este módulo te permitirá detectarlos.

Además es recomendable que verifiques los archivos del servidor.

¿Qué solución aporta  PrestaShop ante esta vulnerabilidad?

La primera acción de Prestashop fue informar  a todos los socios y embajadores sobre la vulnerabilidad, instando a controlar todas las tiendas. Además actualizó los módulos, por tanto para la fecha, son seguros. También revisó los complementos Prestashop a fin de verificar si contenían la vulnerabilidad «phpunit».

Por otra parte, PrestaShop emitió un listado de  archivos problemáticos que posiblemente se hayan incluido en las tiendas comprometidas, por tanto vale la pena revisar su presencia. Estos archivos problemáticos son:

  • XsamXadoo_Bot.php
  • XsamXadoo_deface.php
  • 0x666.php
  • f.php
  • Xsam_Xadoo.html

También recomienda Prestashop, que en caso de tener dudas al respecto, es recomendable cambiar  todas las contraseñas de los usuarios administrativos de tu eCommerce y solicitar a los clientes  que modifiquen las suyas.  Por otra parte, la  información suministrada por Prestashop indica que existen varios módulos que pueden haberse visto afectados afectados por el malware e indican que estos módulos son:

  • Actualización con 1 clic: versiones 4.0 beta y posteriores
  • Cart Abandonment Pro: versiones 2.0.1 ~ 2.0.2
  • Búsqueda por facetas: versiones 2.2.1 ~ 3.0.0
  • Experiencia del comerciante: versiones 2.1.0 y posteriores
  • PrestaShop Checkout: versiones 1.0.8 ~ 1.0.9

A fin de solventar las vulnerabilidades, PrestaShop lanzó nuevas versiones de los módulos posiblemente afectados, eliminando la biblioteca relacionada con el malware y la vulnerabilidad.

Es importante que recuerdes, que si has instalado las versiones comprometidas, continuaras teniendo en el servidor los archivos PHPUnit, por tanto deberás eliminarlos, ya que no servirá de nada instalar las versiones actualizadas sin previamente haber eliminado el malware.

En caso de que tengas dudas sobre si tu sitio web está comprometido, contacta con nosotros para que revisemos tu eCommerce por completo y te asegures de que tus datos y los de tus clientes estén a salvo.